03.11.2025

Поляков р17 №114

# 114)	(П. Волгин) Рассматривается множество целых чисел, принадлежащих числовому
# отрезку [9919; 21987], которые удовлетворяют следующим условиям:
# а) Минимальная цифра в десятичной записи числа равна 3.
# б) Число делится на 2 или на 3, но не делится на 16.
# Найдите количество таких чисел и разность между максимальным и минимальным числами.
#     В ответе запишите сначала количество, а затем разность между максимальным и
# минимальным числами.
num_a = 0
min_num = 14839441241
max_num = -31434141

for i in range (9919, 21988):
    min = int(str(i)[0])
    for a in range(0, len(str(i))):
        if int(str(i)[a]) < min:
            min = int(str(i)[a])
    if min == 3 and (i % 2 == 0 or i % 3 == 0) and i % 16 != 0:
        num_a += 1
        if (i < min_num):
            min_num = i
        if (i > max_num):
            max_num = i
print(num_a, int(max_num - min_num))

Добавить комментарий