02.11.2025

(№ 981) Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – минимальное число, оканчивающееся на 4. 

n=int(input("Введите количество чисел "))
minim=1000000
for i in range(n):
    a=int(input("Введите число "))
    if a%10==4 and a<minim:
        minim=a
print(minim)

Добавить комментарий