02.11.2025

(№ 1042) Напишите программу, которая в последовательности натуральных чисел определяет сумму трёхзначных чисел, кратных 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму трёхзначных чисел, кратных 4.

s=0
for i in range(1000):
    a=int(input("Введите число "))
    if a==0:
        break
    if a>99 and a<1000 and a%4==0:
        s=s+a

print(s)

Добавить комментарий