02.11.2025

(№ 1025) Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое двузначных чисел или сообщает, что таких чисел нет. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое двузначных чисел или вывести NO, если таких чисел в последовательности нет.

s = 0
k = 0
a = 100
for i in range(a):
    b = int(input())
    if b == 0:
        break
    if 9<b<100:
        s+=b
        k+=1


if k == 0:
    print("NO")
else:
    c = s / k
    print(c)

Добавить комментарий