02.11.2025

Напишите программу, которая в последовательности целых чисел определяет количество двузначных чисел, кратных 8. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество двузначных чисел, кратных 8.

k=0
for i in range(1000):
    a=int(input())
    if a==0:
        break
    if a>9 and a<100 and a%8==0:
        k+=1
print(k)

Добавить комментарий