03.11.2025

Напишите программу, которая в последовательности целых чисел определяет количество чётных чисел, кратных 7. Программа
получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести одно число: количество чётных чисел, кратных 7.

s=0
for i in range(1000):
    a=int(input())
    if a==0:
        break
    if a%2==0 and a%7==0:
            s=s+1
print(s)

Добавить комментарий