03.11.2025

Поляков 5-66

#     66) Автомат получает на вход трёхзначное число. По этому числу строится новое
# число по следующим правилам.
# 1. Складываются первая и вторая, а также вторая и третья цифры исходного числа.
# 2. Полученные два числа записываются друг за другом в порядке убывания (без разделителей).
# Пример. Исходное число: 348. Суммы: 3 + 4 = 7; 4 + 8 = 12. Результат: 127.
# Укажите наименьшее число, в результате обработки которого автомат выдаст число 1412.

for N in range(100,1000):
    n=str(N)
    s1=int(n[0])+int(n[1])
    # print(s1)
    s2=int(n[1])+int(n[2])
    # print(s2)
    if s2>s1:
        s=str(s2)+str(s1)
    else:
        s=str(s1)+str(s2)
    # print(s)
    if s=="1412":
        print(N)


Добавить комментарий