03.11.2025

Напишите программу, которая в последовательности целых чисел определяет количество нечётных чисел, кратных 3. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0  — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечётных чисел, кратных 3.

k=0
n=0
for i in range(1000):
    a=int(input("введите число "))
    if a==0:
        break
    n=n+1
    if a%2==1 and a%3==0:
        k=k+1
print(n, k)

Добавить комментарий