03.11.2025

Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. Необходимо определить среднюю зарегистрированную скорость всех автомобилей. Если скорость хотя бы одного автомобиля была не меньше 60 км/ч, выведите «YES», иначе выведите «NO». Программа получает на вход число проехавших автомобилей N (1 ≤ N ≤ 30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300. Программа должна сначала вывести среднюю скорость с точностью до одного знака после запятой, затем «YES» или «NO».

n=int(input("введите n "))
s=0
k=0
rez=0
for i in range(n):
    v=int(input("введите скорость "))
    k+=1
    s+=v
    if v<60:
        rez+=1
print(s/k)
if rez>0:
    print("yes")
else:
    print("no")

Добавить комментарий