02.11.2025

9753

# Текстовый файл состоит из символов T, U, V, W, X, Y и Z.
# Определите в прилагаемом файле максимальное количество идущих
# подряд символов (длину непрерывной подпоследовательности),
# среди которых символ Y встречается не более 150 раз.

file = open('24_9753.txt', 'r').readline()
a = file.split('Y')
smax = 0
for i in range(len(a)-150):
    q = a[i:i+151]
    s = 0
    for x in q:
        s += len(x)
    if smax < s:
        smax = s
print(smax+150)