02.11.2025

Задача из ОГЭ почти на все случаи

# Напишите программу, которая в последовательности целых чисел определяет количество чисел,
# кратных 5 или 9. Программа получает на вход целые числа, количество введённых чисел неизвестно,
# последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в
# последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают
# 30 000. Программа должна вывести одно число: количество чисел, кратных 5 или 9.
# Найти максимуи из них. Найти их сумму. Найти среднее арифметическое. Если таких чисел нет,
# то вывести на экран "NO"
d = 0
s = 0
f = 0
G = 0
for i in range(1000):
    a = int(input())
    if a==0:
        break
    if a%5==0 or a%9==0:
        s+=1
        if a > f:
            f = a
        G = G + a
d = G/s
if s==0:
    print("NO")
print(d) # среднее арифметическое
print(s) # количество 
print(f) # f - максимум
print(G)# Сумма