02.11.2025

14 — 5879

# 3x15x(15) + 123(3x51) + x**x + 1x3(1x3) + 1x2(x+1)
# В записи чисел переменной x обозначена неизвестная цифра. Определите
# наименьшее значение x, при котором значение данного арифметического
# выражения кратно 13. Для найденного значения x вычислите значение
# арифметического выражения и укажите его в ответе в системе счисления с основанием
# 13. Основание системы счисления в ответе указывать не нужно.

def to_thirteen(x):
    s = ''
    while x != 0:
        ost = str(x % 13)
        x //= 13
        if ost == '10':
            s += 'a'
        elif ost == '11':
            s += 'b'
        elif ost == '12':
            s += 'c'
        else:
            s += ost
    return s[::-1]


for x in range(2,10):
    one = 3 * 15 ** 4 + x * 15 ** 3 + 1 * 15 ** 2 + 5 * 15 ** 1 + x
    peremen = int('3' + str(x) +'51')
    two = 1 * peremen ** 2 + 2 * peremen ** 1 + 3
    tree = x ** x
    peremenTwo = int('1' + str(x) + '3')
    four = 1 * peremenTwo ** 2 + x * peremenTwo ** 1 + 3
    five = 1 * (x+1) ** 2 + x * (x+1) ** 1 + 2
    itog = one + two + tree + four + five
    if itog % 13 == 0:
        print(to_thirteen(itog))