02.11.2025

14 — 722

# Значение выражения (55+2*5**x) *5**x+55+5**y ,
# где x, y – натуральные числа, записали в системе счисления с основанием 5.
# Укажите наибольшую возможную сумму цифр этой записи.
def s(x):
    x=str(x)
    sum=0
    for i in range(len(x)):
        sum+=int(x[i])
    return sum
def perev(i):
    s=''
    while i!=0:
        ost= i%5
        i//=5
        s+=str(ost)
    return s [::-1]

m=0
for x in range(1,100):
    for y in range(1, 100):
        n=(55+2*5**x) *5**x+55+5**y
        n=perev(n)
        n=s(int(n))
        if n>m:
            m=n
print(m)