02.11.2025

(№ 1013) Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит NO). Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести среднее арифметическое трёхзначных чисел или вывести NO, если таких чисел нет.

k=0
s=0
f=0
for i in range(100):
    a=int(input("ddd "))
    if a==0:
        break
    if a>99 and a<1000:
        k=k+1
        s=s+a
    else:
        f=f+1
if f==0:
    print("NO")
else:
    print(s/k)

Добавить комментарий