03.11.2025

17 — 9840

# № 9840
# В файле содержится последовательность целых чисел. Элементы последовательности
# могут принимать целые значения от -100 000 до 100 000 включительно. Определите количество
# пар последовательности, в которых только один из элементов является четырёхзначным числом,
# а квадрат суммы элементов пары не больше квадрата максимального элемента последовательности,
# являющегося четырёхзначным числом и оканчивающегося на 39. В ответе запишите количество
# найденных пар чисел, затем максимальную из сумм элементов таких пар. В данной задаче под
# парой подразумевается два идущих подряд элемента последовательности.

arr = list(map(int, open("17_9840 (1).txt").readlines()))
k = 0

def isFour(num):
    if abs(num) >= 1000 and abs(num) <= 9999:
        return True
    return False

for x in range(len(arr)):
    if isFour(arr[x]) == True and abs(arr[x])%100 == 39 and arr[x] > k: k = arr[x]

maxSum = 0
c = 0
for x in range(len(arr)-1):
    if (isFour(arr[x]) == True and isFour(arr[x+1]) == False) or \
            (isFour(arr[x+1]) == True and isFour(arr[x]) == False):
        if (arr[x] + arr[x+1])**2 <= k**2:
            c+=1
            if (arr[x] + arr[x+1]) > maxSum: maxSum = (arr[x] + arr[x+1])



print(maxSum, c)