02.11.2025

(№ 1021) На контрольной работе по алгебре ученикам 9 класса было предложено 10 примеров. Неудовлетворительная оценка выставляется, если правильно решено менее половины примеров. Сколько неудовлетворительных оценок было получено учениками? Если хотя бы один из учеников правильно решил все задачи, выведите YES, иначе выведите NO. Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров.

f=0
k=0
n=int(input("колво участников "))
for i in range(n):
    a=int(input("результат "))
    if a<5:
        k=k+1
    if a==10:
        f=f+1
print(k)
if f>0:
    print("YES")
else:
    print("NO")

Добавить комментарий