03.11.2025

Напишите программу, которая выполняет реверс отдельно
первой и второй половин массива. При изменении значения
N на другое чётное натуральное число программа должна
работать правильно без дополнительных изменений.

a=[0,1,2,3,4,5,6,7,8,9]
for i in range(len(a)//2-1,-1,-1):
    print(a[i],end=' ')
    
for i in range(len(a)-1,len(a)//2-1,-1):
    print(a[i],end=' ')

Добавить комментарий