02.11.2025

Девятиклассники участвовали в викторине по математике. Необходимо было ответить на 20 вопросов. Победителем викторины считается участник, правильно ответивший на наибольшее количество вопросов. На сколько вопросов победитель ответил правильно? Если есть участники викторины, которые не смогли дать правильный ответ ни на один из вопросов, выведите YES, иначе – выведите NO. Гарантируется, что есть участники, правильно ответившие хотя бы на один из вопросов. Программа получает на вход число участников викторины N (1 ≤ N ≤ 50), затем для каждого участника вводится количество вопросов, на которые получен правильный ответ.

n=int(input())
m=-10000
k=0
for i in range(n):
    a=int(input())
    if a>m:
        m=a
    if a==0:
        k+=1
if k>0:
    print("Yes")
else:
    print("No")
print(m)

Добавить комментарий