03.11.2025

(№ 1041) Напишите программу, которая в последовательности натуральных чисел определяетмаксимальное число, оканчивающееся на 3. Программа получает на вход количество чиселв последовательности, а затем сами числа. В последовательности всегда имеется число,оканчивающееся на 3. Количество чисел не превышает 1000. Введённые числа не превышают30 000. Программа должна вывести одно число – максимальное число, оканчивающееся на 3.

n = int(input())
maxim=0
for i in range(n):
    a=int(input())
    if a%10==3:
        if a>maxim:
            maxim=a
print(maxim)