03.11.2025

17 — 248

# В файле 17-243.txt содержится последовательность целых чисел. Элементы последовательности
# могут принимать целые значения от 0 до 10000 включительно. Определите количество пар
# чисел, в которых хотя бы один из двух элементов больше, чем наибольшее из всех чисел в файле,
# делящихся на 119, и хотя бы один элемент из двух оканчивается на 21. В ответе запишите два
# числа: сначала количество найденных пар, а затем – минимальную сумму элементов таких пар.
# В данной задаче под парой подразумевается два идущих подряд элемента последовательности.

f = open("17-243.txt")
mas = list(map(int, f.readlines()))
# print(mas)
m119 = 0
for i in range(len(mas)):
    if mas[i] % 119 == 0 and mas[i] > m119:
        m119 = mas[i]
print(m119)
k = 0
mini = 1000000000
for i in range(len(mas) - 1):
    if (mas[i] > m119 or mas[i + 1] > m119) and (mas[i] % 100 == 21 or mas[i + 1] % 100 == 21):
        k += 1
        if (mas[i] + mas[i + 1]) < mini:
            mini = mas[i] + mas[i + 1]
print(k, mini)